SCIM API Requirements

The SCIM API requirements for CyberArk Identity provisioning vary based on the SCIM version.

SCIM 1.1

SCIM 2.0

GET /Users?count=1

GET /Users?count=1

GET /Users?filter=userName eq

GET /Users?filter=userName eq

GET /Users/

GET /Users/

POST /Users

POST /Users

PUT /Users/

PUT /Users/

GET /Groups

GET /Groups

GET /Groups/

GET /Groups/

POST /Groups

POST /Groups

PATCH /Groups/

PATCH /Groups/

GET /ServiceProviderConfigs

GET /ServiceProviderConfig

GET /Schemas, or both GET /Schemas/User and GET /Schemas/Group

GET /ResourceTypes/User and GET /ResourceTypes/Group

GET /Schemas/<schema_id>

📘

Note

If the application does not support SCIM, you can build SCIM facade middleware, which is the suggested workaround for custom apps.